How do I get a headset working?

Discussion in 'Gotham City' started by ARCHIVED-DeviantBoi, Mar 28, 2012.

  1. I know there's been a bug since like ever with the headsets.

    What steps do I need to take to get it to work with push-to-talk.

    TIA!
  2. Hold right on the d pad when you're speaking. Is that what you're asking?
  3. I press on the D-pad and it doesn't work.

    I can listen to people fine, but I haven't been able to chat myself.

    Do I need to connect the headset before I launch DCUO? Or is it okay to do it once I'm in the game?
  4. what is your sub status... IE f2p, premium, or legendary?

    If F2P you dont get voice chat priveledges

    If you are premium or Legendary then the question is are you using bluetooth or an actual headset?

    If Bluetooth sync it before you launch DCUO
    If headset then make sure its all connected before you launch it and make sure your accessory settings are ALL set to the headset.

    If this is still an issue when you log in check to make sure your headset or bluetooth doesnt have a built in mute that has been turned on
  5. I'm Legendary.
    I have a BT headset. I'll try pairing it before launching DCUO.
    Does push-to-talk work? I hate open mics.
  6. I too am experiencing this same issue. I have a bluetooth headset and all my settings are pointing to the bluetooth. I can hear people but they can't hear me.
    I'll try syncing it before i launch DCUO. I hope that fix the problem....it's annoying trying to do raids and you can't tell people want to do.
  7. yes with bluetooth you HAVE to sync it before you even launch the game. Just as an added measure once you sync it you can go into your accessory settings and check to make sure it synced properly
  8. Like others have said, the easiest way to ensure proper functionality is to sync and power on the headset before launching DCUO.
  9. This is a little late.... but i have a px 21 headset... i've rebooted my system, have all accessory settings set to my px21's. turned voice chat on/off, turned push to talk on/off, messed with each of the individual voice, volume, music, effects settings within the setting tabs and my chatting ability still does not function. when in the ps3 menu's and i adjust/mess with the settings, i hear myself just fine, but when in game, the audio works just fine through my headset, but i get no chat. and yes, the chat is on on my inchord control.... ANYONE HAVE ANY SUGGESTIONS on how to get this working properlY?? it works just fine with my xbox. thanks
  10. DeviantBoi wrote:
    Get the headsets... to work?

    BWAHAHAHAHAHAHAHAHAHAHA
  11. B_Rad60 wrote:
    Somthing I had to do with mine is make sure its plugged in to the Player 1 slot, it wouldn't work in Player 2 for me. You might also check the Chat volume on your control unit. Game and Chat have seperate volume controls on the PX21.
  12. Also, PLEASE …
    As soon as you log into ANY character ANY time EVER … opent the settings in DCUO
    (esc on KB or the Cog next to the Marketplace cart icon)

    Settings >> Audio Options tab >> Input and Output volume
    Nudge them both or you are sure to blow everyones ears out.
  13. DeviantBoi wrote:
    I used to have the same problems with my BT headset, just turn off push to talk save your setting then restart game, even with open mic there gonna be times your mic stop working, to fix this just go to settings turn off mic save your setting wait a few seconds to save, then go again to setting turn on mic then save setting, and the mic work again, after that you have to move your speaker volume bar to not hear extra loud everyone else and the rest not hear extra loud you.
  14. I'd like to point out that while helping DeviantBoi is admirable, his post is from last March. I think it might be too late for him, if he hasn't gotten the help already.
  15. Poor DeviantBoi...... Last logon 5/23.... doesn't get a reply untill 9/25.
    [IMG]
  16. B_Rad60 wrote:
    1. When setting the PS3 Accessories setting, make sure you have the correct px21 chosen. There may be more than one in the drop down, especially if you've hooked it to any USBs.
    2. Test your mic. Make sure you can see the meter respond to your voice. It should be at the top of the green with little or no yellow. There should be no red bars.
    3. Make sure PS3 headset setup is done before starting the DCUO game.
    4. Immediately upon login, go to the Settings tab and move the mic slider back and forth. This will (hopefully) prevent you from blasting people. Next, slide the speaker slider to keep people from blasting you. While you're there, make sure VC and PTT are both On.
    5. Check your channel. If you are in a League, you should default to League channel unless you have a custom audio channel. Upon entering a group or instance, you should automatically switch to group or instance channels if available. Press SELECT to call up the chat, and you can change channels with your triggers while in chat mode.
    6. There is no 6.
    7. TURN DOWN YOUR TV. Yes, the PX21 has a boom instead of the typical BT stubby mic pointed directly at the TV speakers, but it also has full-ear cans.
  17. SoylentBob wrote:
    I have done all those things and nothing corrects the problem. Its is DCUO not the headset.
  18. So the HS does work? You see the talky-talk on the screen?
    Does it work on other games?

    It could be the Update 3 problem. Ever since then, this particular HS has issues. Unfortunately, that may mean you have to turn PTT off and hotmic everything. You can try turning music on and off, but...
  19. try asking a mod to move this to Arkham Asylum
    that might help the problem
    crazy idea i know
  20. SoylentBob wrote:
    Actually my problem is the coms function not working at all. I have tried it with both my turtle beach and my tritons.

    Usually after a phase change it will drop off and never come back, or when I log in it just wont register at all.

Share This Page