Justice League Emblem - Level 30 Mentor Mission Reward Broken.

Discussion in 'Arkham Asylum (Reproducible Bugs)' started by ARCHIVED-WoolySpud, Jan 20, 2011.

  1. Today I hit 30, did the Superman mentor mission, and joined the Justice League. When I finished the quest, I was given a choice between an emblem of the Justice League, or a Tank necklace. Since it's a once per character mission, I'd rather have the emblem, But despite all attempts to choose the JLA Emblem the game has only given me the Necklace.
    The necklace started greyed out and the JLA Emblem looking normal. Under no circumstance was i able to select the emblem. The only thing the Dialog would allow me to do (other then cancel out) is highlight the necklace and press x. This made both the emblem and necklace normal colored. I highlighted the emblem and pressed square to "Choose" as the dialog indicated. Nothing changed, so with the JLA Emblem Highlighted i pressed x. the dialog closed and completed. I checked my inventory and to my disappointment i was given the necklace NOT the emblem.
    Despite every attempt and effort to select the JLA Emblem I was given the necklace instead. I don't know if the intent is to give Both the emblem and the necklace, or if it is one or the other but either way its broken. It wont let you select the emblem and it only gives the necklace reward.
    Several people playing the PC version have been experiencing this too. http://forums.station.sony.com/dcuo...m?topic_id=6914
    Is there any way i can get the JLA Emblem.
    Character Name: Archon Cryos
    Server: Birthright
  2. Had same thing happen to me with Circe as my mentor. Didn't want the necklace.
  3. Odd..
    Last night my wife and I did that one under the Wonder Woman Mentor (we have 2 systems) and both of us could ONLY select the emblem and not the item - I think it too was a necklace!?!
  4. Superman's also my mentor and i hit 30 last night also i tried to get the emblem and they made me get that stupid all red necklace
  5. Bumpity Bump Bump.
    Yeah i'd still like my JLA Emblem. Any word on this? Anyone else having this problem?
  6. ARCHIVED-ace Guest

    Yes both me and my friend, both on ps3, both supermen mentors and both would not let us choose emblem.
  7. I would like my JLA emblem too pls!
  8. Ditto, no emblem, not able to select emblem. Wanted the emblem more then then junk I ended up selling.
  9. Same here. Wonder Woman mentor, couldn't pick the emblem and got stuck with a mediocre necklace. I would really like to actually be able to get the emblem, considering it's a unique style.

    If we can't have them given to us anymore is there a way to make it buyable?
  10. Same here, the killing joke server. Superman as mentor.
  11. also had this problem, i thought i was going crazy, i had tried to choose emblem a few times and it wouldn't light up complete, i went tot he necklace and it would let me highlight that, so i eventually figured i'd get both or something.. no deal. i got the necklace only.... can we redo those instances, maybe a second run will get me the good reward.
  12. same thing happen to me.. it would not let me pick the emblem at all
  13. Crisis server. it let me pick emblem (Superman mentor) but it doesn't show up in the style tabs.
  14. Had this happen to me today.
    I finished "The Justice League" quest, upon going back to The Watchtower and talking to Supergirl, I was given the option to select the Controller Necklace or the Justice League Emblem.
    Wanting the Emblem I quickly found that there was no way to select it. Only the necklace would have the option to press (square) to select it and doing that it would light up "Complete". Unselecting it would offer no option to select the Emblem.
    I don't want to complete the quest until I can select the Emblem.
    Any help would be appreciated.
    Found this http://forums.station.sony.com/dcuo...m?topic_id=8520 post where people said they logged out and then it would work but I did not try this yet.
    And this http://forums.station.sony.com/dcuo...m?topic_id=8412
    EDIT: UPDATE
    I logged in when getting home from work. The quest now ONLY gave me the option to take the emblem and "Complete" was lit.
    So, I clicked on complete since I only wanted the Emblem. Quest completes, I get a feat for joining the Justice League.
    After completeing I went to equip my new emblem, but it's NOT THERE.
    So I got no reward for completing the quest.
    I really would like the Emblem. Please look into this quest.
    SECOND EDIT:
    I'm an idiot. It was in my inventory, I needed to open it and click on it like a collection piece.
    So I got it, but it was weird.
  15. Superman is my mentor and the same exact thing happened with me.
    Myth: Justice
  16. I have the same problem. It only allowed me to choose the ring and not the emblem!
    I want my emblem too!

    Inrage on no mans land
  17. ARCHIVED-BKG Guest

    To confirm this also happened to both my toons.
    Mentor: Lex Luthor
  18. Icetower wrote:
    Same thing here! I just leveled up a 2nd toon and before completeing the quest, I logged out, back in and it would only let me select the emblem. Weirdness, but I was happy!
  19. Same thing happend to me when I reached 30, I was not able to choose the emnblem so i thought that I was getting that, and the other item, kind of upsetting as I woudl have liked the emblem instead. So i have no emblem because I could not choose it. Please find a way to get me this emblem.
  20. Ditto
    was uber bummed when I got the lame arsed necklace. wanted the emblem something fierce.
    name: Doc Troytka
    mentor: batman
    server: no man's land
    power: nature
    weapon: ninja and staff

Share This Page