Game Not Launching From Launcher

Discussion in 'Support: Game Issues' started by HaikenEdge, Sep 24, 2013.

  1. HaikenEdge New Member

    I've been trying to launch this game from Steam, and while the client launches just fine, when I click on Play, nothing happens besides changing to Playing for less than a second; after a few seconds, the launcher simply shuts down, and this doesn't matter whether I press Play once, or repeatedly. I'm simply not able to get the game client to even launch.
  2. Zues Member

    It's NVIDIA drivers. They (Sony) knows about it but launched the game anyway.
  3. starscream New Member

    haiken ive been having the same problem
  4. HaikenEdge New Member

    Well that's tragic, seeing how now I'm going to be uninstalling the game from my computer.
  5. starscream New Member

    im probly going to wait till tomarrow see if they fixed it
  6. ShadowStar New Member

    I use ATI Radion not NVidia
  7. Fred MacManus New Member

    I get the same, but in my case, Steam pops up an "unable to contact key server" box just before shutting down. That tells me that someone didn't anticipate the launch day rush, and didn't get enough servers up and running to meet the demand.
  8. TostuneSilvix New Member

    i have a different graphics card but the nvidia graphics drivers are still installed but the nvidia card is embedded in the motherboard. will uninstalling the nvidia drivers help since im using a different graphics card
    ?
  9. Captain Spacey Pie New Member

    I've been having this issue also. I tried verifying my game to see if I had any missing files, but I don't. Is this happening because the servers are still down from the 9/23/13 downtime? I just downloaded the game yesterday.
  10. Mowpow New Member

    I had the same issue running on Windows 8 64bit. Here's how I fixed it:

    1) Go to c:\program files(x86)\steam\steamapps\common\dragon's prophet
    2) Right click on Launchpad.exe and use "Run as Administrator", click Yes on the consent prompt.
    3) Launch the game. If it gives you an error about a missing dll like DX10----.dll, you had the same issue as I did.
    4) If dx10 message comes up, download the DirectX end-user runtime from here - http://www.microsoft.com/en-us/download/details.aspx?id=35

    It appears that the game uses DirectX 10 still, Windows 8 runs DirectX 11 so you have to install the earlier binaries. Hope this helps someone.

    Mowpow
    Morbidapex likes this.
  11. sazuka441 New Member

    Hey Thanks Mowpow, that actually worked for me :)
  12. Fred MacManus New Member

    As I suspected, once the launch day rush passed, my Steam launcher problems were resolved. I wish that, with games where anticipated demand is high, the people selling keys ensure they have purchased enough server access to process the keys. In this case, Sony wasn't to blame: Steam was. They're the ones who didn't buy enough key server access to support all the keys they sold for launch day.
  13. Saahn New Member

    Mowpow......You da man. Thanks
  14. Morbidapex New Member

    Thanks mowpow, got my game running past the character creation screen but now my game screen just goes white and stops responding, if anybody knows a fix please let me know.

Share This Page