Everquest system requirements.

Discussion in 'General Tech Support Issues (Anything not covered)' started by ARCHIVED-Your-dad-canadian, Nov 7, 2008.

  1. ARCHIVED-Your-dad-canadian Guest

    I was wondering for all the expansions what are the system requirements? I looked them up but people are telling me that thoughs are the old ones the new ones you need atleast 4 gig of ram and all this other stuff. I'm currently doing the 14 day trial and want to buy the game thanks. If anyone can help me out further to see if my cpu cand handle this game my msn is tdot-416@live.ca. Thank you.
  2. ARCHIVED-Fiach_AB Guest

    I have a relatively new main PC with a 2.8Ghz Q6600, 4GB RAM and a 256Mb NVidia 8600GT running Vista. I can run 3 EQ sessions simultaneously with no problems on that. The only change I will make in the near future is to upgrade the graphics card.
    However, I can also run all expansions on my old comp, which is a Pentium 1.4GHz with only 1Gb RAM running under XP. The graphics card is a 128Mb ATI Radeon 9800 PRO.
    I suspect that my old machine is now at the minimum spec for EQ. Hope that helps.
  3. ARCHIVED-TSR-BradW Guest

    Here is a list of the system requirements and the recommended.
    System Requirements

    Required Specs:

    Windows® 98/2000/ME/XP
    Pentium® II 400 equivalent or greater
    256 MB RAM
    ATI Radeon 7500/NVidia GeForce 1 equivalent or greater
    DirectX Compatible Sound Card
    28.8k + Internet Connection
    4X Speed CD-ROM
    500MB - 2.6GB Available Hard Drive Space (depending on how many expansions are installed)
    DirectX 9.0b
    EverQuest Classic and a valid EverQuest account
    * Note: All Direct 3D cards not supported.

    Recommended Specs:

    Windows® 98/2000/ME/XP
    Pentium® 4 equivalent or greater
    512 MB RAM
    NVidia GeForce 3/ATI Radeon 8500 equivalent or greater
    DirectX Compatible Sound Card
    56.6k + Internet Connection
    16X Speed CD-ROM
    3.0+ GB Available Hard Drive Space
    DirectX 9.0b
    EverQuest Classic and a valid EverQuest account
    *Note: DirectX 9.0c or greater is required for all Win 98/ME/2000/XP
    http://www.microsoft.com/directx

Share This Page