Bad performance? Try enabling HPET (Win 7)

Discussion in 'Off Topic Discussion' started by -=Grunt=-, Nov 27, 2012.

  1. HPET stands for High Precision Event Timer. (http://en.wikipedia.org/wiki/High_Precision_Event_Timer)

    This requires changing a setting in the BIOS and Windows command prompt (CMD). Do this at your own risk. I recommend this to people who are comfortable changing a BIOS and Windows CMD setting.

    If your BIOS doesn't have an HPET option, then your hardware does not support HPET.

    The guy means run CMD as admin by the way. Just in case anyone got confused.



    If it's at 14 Mhz, then HPET is fully enabled. If like 3-4 Mhz, then it isn't enabled and Windows is still using the default timer(s).


    Me and my friend's results:
    My friend is able to play Black Ops II smoothly now. It somehow lagged on his i5 and HD 7850... And me? I don't stutter in Planetside 2 when entering new areas also somewhat better FPS, it's really smooth while flying around in my Mossie now.

    I've only tested this with Planetside 2 so far but overall very happy with the results of this 3 minute tweak.
  2. FWIW, my BIOS doesn't have the option for enabling HPET, but WinTestTimer after the command prompt change shows an increase from 2.1 to 14 Mhz.

    I've yet to test for effects ingame or pre- and post- benchmarking, so it's still grain-of-salt..
  3. Lost about 20(even 30) FPS in game :( ... however my Win7 run faster :confused: . Some advice?
  4. If you want to turn it off:

    Run CMD as admin and type:

    bcdedit /deletevalue useplatformclock

    Then turn off HPET in your BIOS.

Share This Page