Fix for the crash to desktop (OutofMemory)! [Please Read]

Discussion in 'General Technical Support' started by Meta Haze, Nov 21, 2012.

  1. I do not like spamming peoples topics. So I will just post this here, I fixed my crashing issue, I'm using Windows 7 home premium 32bit (I think the crashing happens with 32 bit the most due to a memory issue). (due to the Engine accessing memory that is not there, it gets the PlanetSide2.exe has stopped working error)

    I know this is the problem, as it fixed my crashing, I checked in the directory and there was an "outofmemory" txt in there. Check and see if you have one to, if you do, proceed below.

    To fix this, Open CMD prompt with administrator and type in without the parenthesis "bcdedit /set increaseuserva 4000"
    **Change the number 4000 to how much ram you have on your computer, I have 4gb, so its 4000.**
    This fixes the crashing problem in most cases, happens on BF3 and many other games also. In game, instead of crashing you will get occasional 1 second freezes as you did before, but no crashes will happen.

    Always run Steam and Planetside 2 with administrator also.
    • Up x 6
  2. There is a lot more to this then what you stated. You should warn people of the dangers to there machines by doing this.

    Basically - your OS has memory Allocation mapping. Some of your Memory mapping is reserved for the OS only, such as drivers (video). In a 32 bit OS your User (applications,programs like ps2) has 2Gig limit. You are changing the User limit with this switch, However you are taking it from the OS/Driver area.

    Setting the user to high can cause major issues to your pc, Many Video drivers will fail to even load properly. If you attempt this, DO NOT set the User amount to your entire PC's Ram!! You may try around 2304 - 2500. (with 4 gigs you have 2048 for user, and even less for OS as 32bit os does not recognize all 4gig) Also remember, Your video card ram needs to be mapped by the OS !!!!!
    • Up x 2
  3. Niv

    will check tomorrow this way hopefully it will fix , but i got question is there no way to edit it in the windows without using command, so i can remember the original value i had before change.
  4. Telgrin you are making it seem so dangerous, when it actually is not. I've used the BCDEDIT trick for ages, nothing bad ever happens..Besides 4gb for my computer is my max ram, putting the BCD at 4gb fixed my crashes, not 2.5gb, and not anything under and......You can always set it back to the default value if anything goes wrong, if ever. PlanetSide 2 has a memory issue that attempts to grab unaccesible memory, if you have anything under your max Ram in the BCD then it will result in a crash once it attempts to grab that memory...If you have it set at max, then it will be able to grab it without resulting in errors. This happens only on 32 bit W7/Vista, does not happen on 64 bit.

    @Niv: To see your default value, the one you have already before any editing to the BCD, type in "Bcdedit" and then look for "IncreaseUserVa", The number beside it is what your system has by default.
    • Up x 2
  5. Tried it...didnt fix the problem. I guess ill have to wait for a patch.
  6. Ok so i got the whole thing working and did the memory thing but it still crashed and i got another outofmemory message
  7. You have to right click on PlanetSide2.exe and under Privleges, Always run program as an administrator. It allows PlanetSide 2 to do more things with your system. It won't get blocked for any reason.

    Note: Do not even attempt this fix if you do not have an OutofMemory.txt in your PS2 directory! There is no reason to do it, as it fixes the memory issue only.
    • Up x 2
  8. Niv

    when i write in the cmd im geting "the boot configuration data store could not be opened. -> Access is denied"
    any tip to fix this cmd command to work ?
  9. You have to run the CMD (command prompt) at an elevated user level. It also needs to be run as administrator.
  10. Thank You!! this worked for me. I used to crash after 20mins of play, now no crash at all. You Rock!!
  11. Niv

    i am the admin of the pc but it still deny my action in the cmd, any tip?
  12. @Niv: You must right click the CMD prompt and Run as Administrator.


    Bump, for people to see this, very important fix..
  13. Tried it, didn't work.

    I know my out of memory error in APB is due to audio issues with realtek audigy zs
  14. Erm,I try CMD by admin and type in bcdedit,but i didnt see any "Increaseuserva". Do we need type in?
  15. When I tried setting mine to 4GB it still crashed.... I set mine to 2768 and it has been running for hours now. After looking into this tweak, you really shouldn't set it to 4GB, it's a stability and security threat allowing user programs to share the same memory space as the OS.
  16. Niv

    at first i set to 2500 like the guy on 2 post saied but game still crashed, so i raise to 4000 like the original poster said since me and him got same ram and os and it work, from 20 min play time to 2 hour play time, and i put all option from lowest to max :), the game look much better in max settings, i demand the dev team tag this post so it will help all players that crashing.
    and if u wonder didn't had any pc problem since i change this cmd command thing all work like before.
    and about the cmd "denied", u need to search for the cmd.exe and right click it and run as admin.
    • Up x 1
  17. Is there any such command for XP to fix this crashes?

Share This Page