UserOptions for better FPS

Discussion in 'General Technical Support' started by NoNeutrality, Dec 5, 2012.

  1. NoNeutrality

    These are the settings to my Useroptions file that have given me the best fps so far.

    Also, make sure to adjust the resolution to your own monitor

    Also,
    Lower the render quality in-game if your graphics card is the issue.
    or
    Lower your render distance if your cpu or memory is the issue.

    [Display]
    FullscreenRefresh=0
    Maximized=0
    RenderQuality=1.000000
    FullscreenWidth=1360
    FullscreenHeight=768
    WindowedWidth=1024
    WindowedHeight=768
    Mode=Fullscreen
    FullscreenMode=Fullscreen

    [Rendering]
    GraphicsQuality=1
    TextureQuality=3
    ShadowQuality=1
    RenderDistance=2000
    Gamma=0.000000
    MaximumFPS=100
    UseLod0a=1
    OverallQuality=-1
    LightingQuality=1
    EffectsQuality=1
    TerrainQuality=1
    FloraQuality=1
    ModelQuality=1
    VerticalFOV=74
    ParticleLOD=0
    ParticleDistanceScale=0.650000
    FogShadowsEnable=0
    MotionBlur=0
    VSync=0

    [Controls]
    CameraAutoAdjustment=1
    ClickToMove=0
    ClickToMoveRightButton=0
    RailCamera=1

    [Sound]
    Master=0.540000
    Music=0.000000
    Game=1.000000
    Dialog=1.000000
    UI=1.000000
    UseFloat32Output=0
    ExclusiveMode=0
    HitIndicator=1
    LowAmmoIndicator=1
    VehicleChatter=1
    MaxVoices=66

    [VideoCapture]
    Resolution=1
    Quality=5
    OutputFile=C:\Users\NoNeutrality\Videos\Planetside2\PS2Video_0001

    [VideoStreamer]
    Resolution=1
    Fps=30
    Kbps=0
    MicRecordVolume=0.000000
    SpeakerRecordVolume=1.000000
    Username=

    [Terrain]
    RenderFlora=On

    [AutoRefuse]
    FriendInvitation=0
    DuelInvitation=0
    GuildInvitation=0
    HideUi=1
    TradeRequest=0
    HousingInvitation=0
    GroupInvitation=0

    [General]
    AutoDetectPerformanceSettings=0
    Profanity=0
    FlightMouseSensitivity=0.880000
    VehicleMouseSensitivity=0.690000
    FixedMinimap=1
    SprintToggle=0

    [Video]
    VideoCapturePrefix=PS2Video

    [VoiceChat]
    EchoEnabled=1
    EchoVolume=0.500000
    ProximityEnabled=1
    ProximityVolume=0.500000
    FactionEnabled=1
    FactionVolume=0.500000
    GroupEnabled=1
    GroupVolume=0.500000
    GroupLeaderEnabled=1
    GroupLeaderVolume=0.500000
    RaidEnabled=1
    RaidVolume=0.500000
    GuildEnabled=1
    GuildVolume=0.500000
    CustomEnabled=1
    CustomVolume=0.500000

    [Voice]
    ReceiveVolume=81.000000
    MicrophoneVolume=22.000000

    [UI]
    WelcomeScreenShown=1
    MapZoomLevel=0
    MapPositionX=200
    MapPositionY=75.51582335058629
    ShowMapTutorial=0
    MapCenterOnPlayer=0
    ShowCertsTutorial=0
    MapStatisticsView=1
    MapFilterShowSquad=1
    MapFilterShowActivityLevel=0
    MapFilterShowTerritoryControl=1
    MapFilterShowGrid=1
    MapFilterShowMissions=1
    MapFilterShowFacilities=1
    MapFilterShowResource1=1
    MapFilterShowResource2=1
    MapFilterShowResource3=1
    CentralizedHudMode=0
    • Up x 1
  2. Streetfighter

    MaximumFPS=20

    :eek:
    • Up x 1
  3. RealRyder

    Thanks man. Played several hours today, and there were no problems in the larger battles. This game is awesome. Peace.
  4. Lee

    Most of my outfitmates and I run with a render distance of 1000 or lower. It's still ok for most of the situations, might just be annoying when you hot drop as the landing location will render later, but for the rest it's ok and improve performance a lot.

    Have you tried RenderFlora = Off?
  5. NoNeutrality

    Actualy i did recently turn floral and shadows off, it made a HUGE difference.
  6. ERICH

    whats ParticleDistanceScale=0.650000 ?
  7. badname02

    My main problem is that the ONLY (and I truly mean ONLY) settings that affect my GPU performance are:

    ShadowQuality=0
    RenderDistance=1500

    ... and that's it. The rest can be put to high and I'll lose 3 fps average when compared to super-low everything. Because, like most people, it's my CPU \ game optimization that's the main issue for me. I enjoy the game either way, but any extra performance I would loooooove to have it.
  8. Archaegeo

    Try setting Graphics Qualiy to Low, then adjust all others. Its a big FPS hit
  9. Flachzang

    My problem is that I cant turn off the shadows and flora!

    Although i set "ShadowQuality=0" and "RenderFlora=Off" they are not disabled ingame. When I go back to the UserOptions.ini, I can see that ShadowQuality is back on 1. And while RenderFlora is still Off in the UserOptions it is still displayed ingame, too.

    Any idea?
  10. LucKy232

    Make the file read-only and it will stay that way. And it will work.
  11. Flachzang

    Thx for the tip but unfortunately it doesn't work. ShadowQuality stays on 0 now, but there are still shadows ingame as well as flora.
  12. badname02

    Your problem is this:

    ''OverallQuality=-1''

    That's right. Change that to -1 as above ^

    Now you'll have no more shadows.

    I had the same issue as you untill I figured this one out ;)


    So you do:

    ShadowQuality=0
    OverallQuality=-1

    Read-Only

    Restart client: done. 100% guaranteed fix.
    Setting OverallQuality=-1 means you're using a custom setting and without it non-ingame settings won't work properly.
  13. Flachzang

    Indeed ! Shadows are off and I welcome the additional 10-20 FPS :) Thank you, Sir!

    But I'm a bit confused, I play on Indar right now and I can still see bushes and those palm-cactus-tree-things. Isn't RenderFlora=Off meant to disable them? I'm not sure if this is correct...
    • Up x 1
  14. Cl1mh4224rd

    Setting it to read-only is unnecessary and I, personally, would not recommend it. First, I've heard that it doesn't even work anymore. Second, even if it did, it would prevent you from changing most settings (like mouse sensitivity) from within the game itself.

    Actually, no. I guess that's technically terrain. The flora is just the tall grass and flowers.
    • Up x 1
  15. badname02

    No RenderFlora=Off means that there's no more grass etc. But some bushes and trees remain. ;) And you're welcome!

    Why not? If you change anything in-game it WILL change, but be changed BACK to what you set in your UserOptions.ini the next time you start the client... Try it yourself ;)

    But I think the problem was that he didn't have the ''OverallQuality=-1'' setting =p

    Glad to see it works now anyway!
  16. LucKy232

    It does prevent you from doing that, but without it, the game would revert the ShadowQuality to 1 instead of 0, like he described.
  17. badname02

    Then why can I simply change stuff in-game whilst having it set to read only... I reverts to what's set in the file when you restart the client. Trust me I've been messing around with that thing since day 1.

    If I change my render options in-game whilst the thing is locked to read only, it still changes, but it just won't stay every time you log in.

    For instance if I want to try a new sensitivity: it'll change. But when I restart the game it's back to whatever I set it at in the useroptions.ini

    graphical changes don't count since most of those don't change till you restart anyway =p
  18. Cl1mh4224rd

    True, but no one should be expected to have to reset things like their mouse sensitivity every time they play the game. It's either that or: exit the game, uncheck Read-Only, manually make the change, recheck Read-Only, restart the game. Kind of a pain if you just want to tweak your mouse sensitivity. ;)

    Agreed.
  19. badname02

    Hmmm... I just tested this and it's weird but when you've set the OverallQuality=-1 and ShadowQuality=0 you don't need ''read only'' anymore o_O

    I have that off right now so I can ineed, as you said, tweak my sensitivity which I'm messing around with at the moment and the shadows stay off every time I restart the client....

    No idea how or why, but I'm glad it does!
  20. LucKy232

    The settings are probably loaded in the RAM before the game starts loading, so it knows what to do every loading screen or every time it renders something without looking into the HDD every time.
    The bus (=deals with data transfer) and response time between the RAM memory and the CPU or GPU are much, much faster than the one between the HDD and CPU or GPU, so it doesn't have to wait for the response from the HDD.

    I might be wrong, but that makes sense to me.

    It's weird if it works without read-only, it didn't before. I should try that again.

Share This Page